CVE-2022-4928
A vulnerability was found in icplayer up to 0.819.
Does this matter?
Lower severity and a low EPSS score (0.51%). Track it; it rarely justifies an emergency change on its own.
Description
A vulnerability was found in icplayer up to 0.819. It has been declared as problematic. Affected by this vulnerability is the function AddonText_Selection_create of the file addons/Text_Selection/src/presenter.js. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.820 is able to address this issue. The identifier of the patch is 2223628e6db1df73f6d633d2c0422d995990f0a3. It is recommended to upgrade the affected component. The identifier VDB-222289 was assigned to this vulnerability.
- CVSS 3.1
- 6.1 MEDIUMCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- 0.51% probability · 43th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-79
- Affected
- learnetic/icplayer
- Source
- cna@vuldb.com
EPSS 0.5% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/icplayer/icplayer/commit/2223628e6db1df73f6d633d2c0422d995990f0a3Patch
- https://github.com/icplayer/icplayer/pull/881Patch
- https://github.com/icplayer/icplayer/releases/tag/v0.820Release Notes
- https://vuldb.com/?ctiid.222289Permissions Required
- https://vuldb.com/?id.222289Permissions Required
- https://github.com/icplayer/icplayer/commit/2223628e6db1df73f6d633d2c0422d995990f0a3Patch
- https://github.com/icplayer/icplayer/pull/881Patch
- https://github.com/icplayer/icplayer/releases/tag/v0.820Release Notes
- https://vuldb.com/?ctiid.222289Permissions Required
- https://vuldb.com/?id.222289Permissions Required
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.