CVE-2019-7139
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage.
Does this matter?
EPSS puts the probability of exploitation in the next 30 days at 22.2%, higher than 98% of all known CVEs. Patch or mitigate before the next change window.
Description
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.
- CVSS 3.0
- 9.8 CRITICALCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- 22.24% probability · 98th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-89
- Affected
- magento/magento
- Source
- psirt@adobe.com
EPSS moved from 9.9% on 21 September 2026 to 22.2% on 26 October 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.
References
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
- https://www.ambionics.io/blog/magento-sqliExploit, Third Party Advisory
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
- https://www.ambionics.io/blog/magento-sqliExploit, Third Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.