CVE-2026-55573
Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes.
Does this matter?
High impact if exploited, but EPSS currently rates exploitation as unlikely (0.70%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.
Description
e107 is a content management system (CMS). Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes. The installer remains accessible after a normal installation, and a crafted object graph using the bundled GuzzleHttp\Psr7\PumpStream class can flow through paths.hash into site_path, where string coercion invokes an attacker-controlled callable. An unauthenticated attacker who can reach install.php can therefore execute arbitrary PHP functions with the web server process's privileges, leading to full server compromise. This issue is fixed in version 2.3.7.
- CVSS 3.1
- 9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- 0.70% probability · 53th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-502
- Source
- security-advisories@github.com
EPSS moved from 0.6% on 15 October 2026 to 0.7% on 26 October 2026.
References
- https://github.com/e107inc/e107/commit/5d6d649e8cf01854d6024d07997c2449fdd75f24
- https://github.com/e107inc/e107/commit/6c404295213952aedb9b3689be19dd4c7ba550b0
- https://github.com/e107inc/e107/releases/tag/v2.3.7
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.