{"id":"CVE-2026-55573","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-55573","generatedAt":"2026-10-28T02:56:58.236Z","title":"Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes.","description":"e107 is a content management system (CMS). Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes. The installer remains accessible after a normal installation, and a crafted object graph using the bundled GuzzleHttp\\Psr7\\PumpStream class can flow through paths.hash into site_path, where string coercion invokes an attacker-controlled callable. An unauthenticated attacker who can reach install.php can therefore execute arbitrary PHP functions with the web server process's privileges, leading to full server compromise. This issue is fixed in version 2.3.7.","published":"2026-10-14T18:17:38.000Z","lastModified":"2026-10-16T20:04:30.000Z","status":"Deferred","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":9.8,"severity":"CRITICAL","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"},"cwe":["CWE-502"],"affected":[],"epss":{"score":0.00704,"percentile":0.53048,"date":"2026-10-26","history":[{"date":"2026-10-15","score":0.00595,"percentile":0.47248}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.70%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-14T18:17:38.000Z","detail":{"score":"9.8","severity":"CRITICAL","publishedAt":"2026-10-14T18:17:38.013Z"},"summary":"New CVE, critical severity (CVSS 9.8)."}],"references":[{"url":"https://github.com/e107inc/e107/commit/5d6d649e8cf01854d6024d07997c2449fdd75f24","source":"security-advisories@github.com"},{"url":"https://github.com/e107inc/e107/commit/6c404295213952aedb9b3689be19dd4c7ba550b0","source":"security-advisories@github.com"},{"url":"https://github.com/e107inc/e107/releases/tag/v2.3.7","source":"security-advisories@github.com"},{"url":"https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8","source":"security-advisories@github.com"},{"url":"https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8","source":"134c704f-9b21-4f2e-91b3-4a467353bcc0"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-55573","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}