SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityAnalyzed

CVE-2026-41268

Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability.

CRITICAL 9.8EPSS 17.4%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 17.4%, higher than 97% of all known CVEs. Patch or mitigate before the next change window.

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

CVSS 3.1
9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
17.44% probability · 97th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-20
Affected
flowiseai/flowise
Source
security-advisories@github.com
EPSS trend
0%10%20%24 September 2026: 1.25%25 October 2026: 17.44%30 October 2026: 17.44%24 September 202630 October 2026

EPSS moved from 1.2% on 24 September 2026 to 17.4% on 30 October 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.