{"id":"CVE-2026-41268","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-41268","generatedAt":"2026-10-31T04:55:46.609Z","title":"Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability.","description":"Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.","published":"2026-04-23T20:16:15.000Z","lastModified":"2026-10-26T22:10:00.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":9.8,"severity":"CRITICAL","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"},"cwe":["CWE-20"],"affected":["flowiseai/flowise"],"epss":{"score":0.1744,"percentile":0.97123,"date":"2026-10-30","history":[{"date":"2026-09-24","score":0.01247,"percentile":0.68006},{"date":"2026-10-25","score":0.1744,"percentile":0.97104}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"urgent","text":"EPSS puts the probability of exploitation in the next 30 days at 17.4%, higher than 97% of all known CVEs. Patch or mitigate before the next change window."},"changes":[{"kind":"epss","label":"EPSS jump","at":"2026-10-25T00:00:00.000Z","detail":{"to":0.1744,"from":0.01247,"percentile":0.97104},"summary":"EPSS moved from 1.2% to 17.4% probability of exploitation in the next thirty days."}],"references":[{"url":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6","tags":["Exploit","Vendor Advisory"],"source":"security-advisories@github.com"},{"url":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6","tags":["Exploit","Vendor Advisory"],"source":"134c704f-9b21-4f2e-91b3-4a467353bcc0"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-41268","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}