CVE-2026-63000
Prior to 5.21.2, rex_api_install_package_update in redaxo/src/addons/install/lib/api/api_package_update.php inherits the false default from rex_api_function::requiresCsrfProtection() instead of requiring a CSRF token.
Does this matter?
Lower severity and a low EPSS score (0.15%). Track it; it rarely justifies an emergency change on its own.
Description
REDAXO is a PHP-based content management system. Prior to 5.21.2, rex_api_install_package_update in redaxo/src/addons/install/lib/api/api_package_update.php inherits the false default from rex_api_function::requiresCsrfProtection() instead of requiring a CSRF token. An unauthenticated attacker can cause a logged-in administrator's browser to request a selected package update from the configured REDAXO package server, changing installed addon code or disrupting the site without the administrator's intent. This issue is fixed in version 5.21.2.
- CVSS 3.1
- 6.4 MEDIUMCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:L
- EPSS
- 0.15% probability · 4th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-352
- Affected
- redaxo/redaxo
- Source
- security-advisories@github.com
EPSS moved from 0.1% on 24 September 2026 to 0.1% on 26 October 2026.
References
- https://github.com/redaxo/core/commit/a13abbffbad4fdea46a4edc86cdba3335ca9e8f3Patch
- https://github.com/redaxo/core/pull/6579Issue Tracking, Patch
- https://github.com/redaxo/core/releases/tag/5.21.2Release Notes
- https://github.com/redaxo/core/security/advisories/GHSA-m8r3-22v6-g877Exploit, Vendor Advisory
- https://github.com/redaxo/core/security/advisories/GHSA-m8r3-22v6-g877Exploit, Vendor Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.