SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityAnalyzed

CVE-2026-42271

BerriAI LiteLLM Command Injection Vulnerability

KEVHIGH 8.7EPSS 91.4%

Does this matter?

Known to be exploited in the wild (CISA KEV, CISA remediation deadline 22 June 2026). Treat as an emergency change: patch or isolate now, then hunt for prior compromise.

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

CVSS 4.0
8.7 HIGHCVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M
EPSS
91.44% probability · 100th percentile
Public exploits
None in Exploit-DB
CISA KEV
Listed 8 June 2026 · due 22 June 2026
Weakness
CWE-77, CWE-78
Affected
litellm/litellm · redhat/openshift ai
Source
security-advisories@github.com
EPSS trend
0%48%95%24 September 2026: 12.75%29 September 2026: 92.57%25 October 2026: 91.44%27 October 2026: 91.44%24 September 202627 October 2026

EPSS moved from 12.8% on 24 September 2026 to 91.4% on 27 October 2026, peaking at 92.6% on 29 September 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.

CISA notes

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. This vulnerability affects a common open-source component, third-party library, or a protocol used by different products. Please check with specific vendors for information on patching status. For more information, please see: https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g ; https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable ; https://nvd.nist.gov/vuln/detail/CVE-2026-42271

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.