SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityAnalyzed

CVE-2026-41501

Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130.

CRITICAL 9.8EPSS 1.29%

Does this matter?

High impact if exploited, but EPSS currently rates exploitation as unlikely (1.29%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.

Description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.

CVSS 3.1
9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.29% probability · 70th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-77
Affected
electerm project/electerm
Source
security-advisories@github.com
EPSS trend
0%3%5%24 September 2026: 2.49%25 October 2026: 1.29%26 October 2026: 1.29%24 September 202626 October 2026

EPSS moved from 2.5% on 24 September 2026 to 1.3% on 26 October 2026.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.