CVE-2026-19041
A vulnerability has been found in MissionSquad mcp-api up to 1.11.8.
Does this matter?
Lower severity and a low EPSS score (2.12%). Track it; it rarely justifies an emergency change on its own.
Description
A vulnerability has been found in MissionSquad mcp-api up to 1.11.8. The impacted element is the function this.packageService.installPackage of the file src/controllers/packages.ts of the component NPM Package Version Handler. The manipulation leads to command injection. It is possible to initiate the attack remotely. Upgrading to version 1.11.9 is sufficient to resolve this issue. The identifier of the patch is a40f54d4533ba6618e1749383a245900eeb024c1. The affected component should be upgraded.
- CVSS 4.0
- 2.1 LOWCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M
- EPSS
- 2.12% probability · 82th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-74, CWE-77
- Source
- cna@vuldb.com
EPSS 2.1% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/MissionSquad/mcp-api/
- https://github.com/MissionSquad/mcp-api/commit/a40f54d4533ba6618e1749383a245900eeb024c1
- https://github.com/MissionSquad/mcp-api/issues/41
- https://github.com/MissionSquad/mcp-api/pull/44
- https://github.com/MissionSquad/mcp-api/releases/tag/v1.11.9
- https://vuldb.com/cve/CVE-2026-19041
- https://vuldb.com/submit/863830
- https://vuldb.com/vuln/386460
- https://vuldb.com/vuln/386460/cti
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.