CVE-2026-12241
The Advanced Woo Labels – Product Labels & Badges for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improperly secure capability check on the 'save_meta_boxes' function in all versions up to, and…
Does this matter?
Lower severity and a low EPSS score (0.19%). Track it; it rarely justifies an emergency change on its own.
Description
The Advanced Woo Labels – Product Labels & Badges for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improperly secure capability check on the 'save_meta_boxes' function in all versions up to, and including, 2.51. This makes it possible for authenticated attackers, with Contributor-level access and above, to create AWS labels that are rendered without proper escaping. The vulnerability was partially patched in version 2.46.
- CVSS 3.1
- 5.4 MEDIUMCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- 0.19% probability · 9th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-79
- Source
- security@wordfence.com
EPSS moved from 0.2% on 2 October 2026 to 0.2% on 26 October 2026.
References
- https://kramakit.com/guide/free-version-changelog-awl/
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/advanced-woo-labels.php#L219
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/admin/class-awl-admin.php#L121
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/class-awl-label-view.php#L145
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/class-awl-taxonomy.php#L116
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/class-awl-taxonomy.php#L78
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a08d9118-3615-4f8e-a1cc-ba7e7873b7e5?source=cve
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.