CVE-2026-112159
A security vulnerability has been detected in JumpServer up to 4.10.19.
Does this matter?
Lower severity and a low EPSS score (1.04%). Track it; it rarely justifies an emergency change on its own.
Description
A security vulnerability has been detected in JumpServer up to 4.10.19. The affected element is an unknown function of the component Template Rendering. The manipulation of the argument IP/HOST leads to os command injection. Remote exploitation of the attack is possible. The exploit has been disclosed publicly and may be used. Upgrading to version 5.0.0 is sufficient to fix this issue. The identifier of the patch is fcf2904cdb884230e9676f50f37a44d09fa97040. The affected component should be upgraded. The vendor confirms: "This issue was identified quite some time ago, and we have already fixed it in the v5 branch. (...) The fix will also be included in an upcoming v4 release.
- CVSS 4.0
- 2.0 LOWCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M
- EPSS
- 1.04% probability · 64th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-77, CWE-78
- Source
- cna@vuldb.com
EPSS moved from 0.9% on 20 October 2026 to 1.0% on 27 October 2026.
References
- https://gist.github.com/Seikruun/b628bb6d4403d9c41a54a4b92d775583
- https://github.com/jumpserver/jumpserver/
- https://github.com/jumpserver/jumpserver/commit/fcf2904cdb884230e9676f50f37a44d09fa97040
- https://github.com/jumpserver/jumpserver/pull/17500/
- https://github.com/jumpserver/jumpserver/releases/tag/v5.0.0
- https://vuldb.com/cve/CVE-2026-112159
- https://vuldb.com/submit/964676
- https://vuldb.com/vuln/422286
- https://vuldb.com/vuln/422286/cti
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.