CVE-2026-108836
A vulnerability has been found in Ollama up to 0.34.1.
Does this matter?
Lower severity and a low EPSS score (0.47%). Track it; it rarely justifies an emergency change on its own.
Description
A vulnerability has been found in Ollama up to 0.34.1. The affected element is the function IsValid of the file types/model/name.go of the component Pull API. The manipulation leads to server-side request forgery. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.34.2 is sufficient to fix this issue. The identifier of the patch is dfabde4539e42ba1e1eab50a3a50b88aea7958a0. It is suggested to upgrade the affected component.
- CVSS 4.0
- 5.5 MEDIUMCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M
- EPSS
- 0.47% probability · 40th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-918
- Source
- cna@vuldb.com
EPSS moved from 0.5% on 13 October 2026 to 0.5% on 26 October 2026.
References
- https://github.com/aLtEr6/test.git
- https://github.com/aLtEr6/test/blob/main/test.pdf
- https://github.com/ollama/ollama/
- https://github.com/ollama/ollama/commit/dfabde4539e42ba1e1eab50a3a50b88aea7958a0
- https://github.com/ollama/ollama/pull/18512
- https://github.com/ollama/ollama/releases/tag/v0.34.2
- https://vuldb.com/cve/CVE-2026-108836
- https://vuldb.com/submit/972855
- https://vuldb.com/vuln/416610
- https://vuldb.com/vuln/416610/cti
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.