CVE-2026-106509
Prior to 1.14.6, the @backstage/plugin-techdocs-node package is affected by improper validation of mkdocs theme configuration in techdocs.
Does this matter?
High impact if exploited, but EPSS currently rates exploitation as unlikely (0.52%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.
Description
Backstage is an open framework for building developer portals. Prior to 1.14.6, the @backstage/plugin-techdocs-node package is affected by improper validation of mkdocs theme configuration in techdocs. When TechDocs is configured to build documentation locally or in a container, a user with write access to a registered repository can include configuration values in mkdocs.yml that cause arbitrary code execution during the documentation build process. This issue is fixed in versions 1.14.6 and 1.15.4.
- CVSS 3.1
- 8.8 HIGHCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- 0.52% probability · 44th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-94, CWE-1336
- Affected
- linuxfoundation/backstage plugin-techdocs-node · linuxfoundation/backstage
- Source
- security-advisories@github.com
EPSS moved from 0.3% on 7 October 2026 to 0.5% on 26 October 2026.
References
- https://github.com/backstage/backstage/commit/02cd7cdbb18b687446277b5602adaee7f1d53cbbExploit, Patch
- https://github.com/backstage/backstage/commit/a900a9953c8f7ad3ba1906d1d257725a9996cc9dExploit, Patch
- https://github.com/backstage/backstage/releases/tag/v1.50.5Release Notes
- https://github.com/backstage/backstage/releases/tag/v1.54.6Release Notes
- https://github.com/backstage/backstage/security/advisories/GHSA-8w7q-29mw-gf5cVendor Advisory, Mitigation
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.