CVE-2026-106492
Prior to 0.16.1 and 0.17.8, the @backstage/backend-defaults package is affected by improper preservation of access restrictions during service credential delegation.
Does this matter?
Lower severity and a low EPSS score (0.21%). Track it; it rarely justifies an emergency change on its own.
Description
Backstage is an open framework for building developer portals. Prior to 0.16.1 and 0.17.8, the @backstage/backend-defaults package is affected by improper preservation of access restrictions during service credential delegation. An external service credential configured with access restrictions (e.g., read-only) could bypass those restrictions by routing requests through plugin delegation paths. This could allow a restricted service to perform operations beyond its intended scope, including write operations on plugins it was restricted to read-only access for. This issue is fixed in versions 0.16.1 and 0.17.8.
- CVSS 3.1
- 6.5 MEDIUMCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- 0.21% probability · 11th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-269, CWE-863
- Affected
- linuxfoundation/backstage\/backend-defaults · linuxfoundation/backstage
- Source
- security-advisories@github.com
EPSS moved from 0.2% on 7 October 2026 to 0.2% on 26 October 2026.
References
- https://github.com/backstage/backstage/commit/40346245c53e1bf26dee56601e95c5c4ab9cc124Patch
- https://github.com/backstage/backstage/commit/bc80ffdafbc92ff7b8c72347eace13cb8688fd33Patch
- https://github.com/backstage/backstage/releases/tag/v1.49.6Patch, Release Notes
- https://github.com/backstage/backstage/releases/tag/v1.54.6Patch, Release Notes
- https://github.com/backstage/backstage/security/advisories/GHSA-cq7v-rfgc-5c7vMitigation, Vendor Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.