CVE-2026-103534
A vulnerability was determined in David-Crty databasement up to 1.7.1.
Does this matter?
Lower severity and a low EPSS score (0.26%). Track it; it rarely justifies an emergency change on its own.
Description
A vulnerability was determined in David-Crty databasement up to 1.7.1. Affected is the function SnapshotPolicy.viewAny/SnapshotPolicy.view of the file /api/v1/snapshots of the component Snapshot Model. This manipulation causes improper access controls. Remote exploitation of the attack is possible. The exploit has been publicly disclosed and may be utilized. Upgrading to version 1.7.2 is able to address this issue. The affected component should be upgraded.
- CVSS 4.0
- 2.1 LOWCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M
- EPSS
- 0.26% probability · 17th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-266, CWE-284
- Source
- cna@vuldb.com
EPSS moved from 0.2% on 2 October 2026 to 0.3% on 27 October 2026.
References
- https://github.com/David-Crty/databasement/
- https://github.com/David-Crty/databasement/releases/tag/v1.7.2
- https://github.com/David-Crty/databasement/security/advisories/GHSA-vx6q-v2gv-5fhv
- https://vuldb.com/cve/CVE-2026-103534
- https://vuldb.com/submit/957818
- https://vuldb.com/vuln/412346
- https://vuldb.com/vuln/412346/cti
- https://github.com/David-Crty/databasement/security/advisories/GHSA-vx6q-v2gv-5fhv
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.