SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityDeferred

CVE-2025-53107

Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands.

HIGH 7.5EPSS 24.5%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 24.5%, higher than 98% of all known CVEs. Patch or mitigate before the next change window.

Description

@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.

CVSS 3.1
7.5 HIGHCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
24.54% probability · 98th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-77
Source
security-advisories@github.com
EPSS trend
0%13%25%2 October 2026: 24.54%26 October 2026: 24.54%2 October 202626 October 2026

EPSS moved from 24.5% on 2 October 2026 to 24.5% on 26 October 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.