SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityDeferred

CVE-2025-49596

Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio.

CRITICAL 9.4EPSS 44.5%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 44.5%, higher than 99% of all known CVEs. Patch or mitigate before the next change window.

Description

The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.

CVSS 4.0
9.4 CRITICALCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M
EPSS
44.45% probability · 99th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-306
Source
security-advisories@github.com
EPSS trend
0%23%45%1 November 2026: 44.45%1 November 20261 November 2026

EPSS 44.5% since 1 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.