CVE-2024-54779
Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds is vulnerable to Cross Site Scripting (XSS) in widgets/log.widget.php.
Does this matter?
Lower severity and a low EPSS score (8.52%). Track it; it rarely justifies an emergency change on its own.
Description
Netgate pfSense CE (prior to 2.8.0 beta release) and corresponding Plus builds is vulnerable to Cross Site Scripting (XSS) in widgets/log.widget.php.
- CVSS 3.1
- 5.4 MEDIUMCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- 8.52% probability · 95th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-79
- Affected
- netgate/pfsense ce · netgate/pfsense plus
- Source
- cve@mitre.org
EPSS 8.5% since 26 October 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://blog.brillantit.com/exploiting-pfsense-xss-command-injection-cloud-hijack/Exploit, Third Party Advisory
- https://docs.netgate.com/downloads/pfSense-SA-25_01.webgui.ascMailing List, Vendor Advisory
- https://www.netgate.com/blog/important-security-updates-for-pfsense-plus-24.11-and-ce-2.7.2Release Notes
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.