CVE-2024-52279
Improper Input Validation vulnerability in Apache Zeppelin.
Does this matter?
Lower severity and a low EPSS score (1.05%). Track it; it rarely justifies an emergency change on its own.
Description
Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
- CVSS 3.1
- 5.3 MEDIUMCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- 1.05% probability · 64th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-20
- Affected
- apache/zeppelin
- Source
- security@apache.org
EPSS 1.1% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/apache/zeppelin/pull/4838Issue Tracking
- https://issues.apache.org/jira/browse/ZEPPELIN-6095Issue Tracking
- https://lists.apache.org/thread/dxb98vgrb21rrl3k0fzonpk66onr6o4qVendor Advisory
- https://www.cve.org/CVERecord?id=CVE-2024-31864Not Applicable
- http://www.openwall.com/lists/oss-security/2025/08/03/3
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.