SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityAnalyzed

CVE-2024-45216

Improper Authentication vulnerability in Apache Solr.

CRITICAL 9.8EPSS 92.7%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 92.7%, higher than 100% of all known CVEs. Patch or mitigate before the next change window.

Description

Improper Authentication vulnerability in Apache Solr. Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.

CVSS 3.1
9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
92.75% probability · 100th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-287, CWE-863
Affected
apache/solr
Source
security@apache.org
EPSS trend
0%48%95%27 September 2026: 92.75%3 November 2026: 92.75%27 September 20263 November 2026

EPSS moved from 92.7% on 27 September 2026 to 92.7% on 3 November 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.