SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2024-34693

Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled.

MEDIUM 5.3EPSS 1.58%

Does this matter?

Lower severity and a low EPSS score (1.58%). Track it; it rarely justifies an emergency change on its own.

Description

Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0 Users are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.

CVSS 3.1
5.3 MEDIUMCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
1.58% probability · 75th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-20
Affected
apache/superset
Source
security@apache.org
EPSS trend
0%3%5%26 October 2026: 1.58%26 October 202626 October 2026

EPSS 1.6% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.