CVE-2024-30269
DataEase, an open source data visualization and analysis tool, has a database configuration information exposure vulnerability prior to version 2.5.0.
Does this matter?
EPSS puts the probability of exploitation in the next 30 days at 15.9%, higher than 97% of all known CVEs. Patch or mitigate before the next change window.
Description
DataEase, an open source data visualization and analysis tool, has a database configuration information exposure vulnerability prior to version 2.5.0. Visiting the `/de2api/engine/getEngine;.js` path via a browser reveals that the platform's database configuration is returned. The vulnerability has been fixed in v2.5.0. No known workarounds are available aside from upgrading.
- CVSS 3.1
- 5.3 MEDIUMCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- 15.88% probability · 97th percentile
- Public exploits
- 1 in Exploit-DB · first 6 April 2025
- CISA KEV
- Not listed
- Weakness
- CWE-200
- Affected
- dataease/dataease
- Source
- security-advisories@github.com
EPSS 15.9% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
Public exploits (1)
Entries in Exploit-DB that cite this CVE. Links go to the Exploit-DB page and to the file in the public repository; nothing is hosted here. A verified tick means the Exploit-DB team confirmed the exploit works against the stated version.
References
- https://github.com/dataease/dataease/releases/tag/v2.5.0Release Notes
- https://github.com/dataease/dataease/security/advisories/GHSA-8gvx-4qvj-6vv5Vendor Advisory
- https://github.com/dataease/dataease/releases/tag/v2.5.0Release Notes
- https://github.com/dataease/dataease/security/advisories/GHSA-8gvx-4qvj-6vv5Vendor Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.