SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2024-27919

In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames.

HIGH 7.5EPSS 86.7%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 86.7%, higher than 100% of all known CVEs. Patch or mitigate before the next change window.

Description

Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.

CVSS 3.1
7.5 HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
86.75% probability · 100th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-390
Affected
envoyproxy/envoy
Source
security-advisories@github.com
EPSS trend
0%45%90%3 November 2026: 86.75%3 November 20263 November 2026

EPSS 86.7% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.