SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2024-25111

Starting in version 3.5.27 and prior to version 6.8, Squid may be vulnerable to a Denial of Service attack against HTTP Chunked decoder due to an uncontrolled recursion bug.

HIGH 7.5EPSS 65.3%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 65.3%, higher than 99% of all known CVEs. Patch or mitigate before the next change window.

Description

Squid is a web proxy cache. Starting in version 3.5.27 and prior to version 6.8, Squid may be vulnerable to a Denial of Service attack against HTTP Chunked decoder due to an uncontrolled recursion bug. This problem allows a remote attacker to cause Denial of Service when sending a crafted, chunked, encoded HTTP Message. This bug is fixed in Squid version 6.8. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. There is no workaround for this issue.

CVSS 3.1
7.5 HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
65.25% probability · 99th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-674
Affected
squid-cache/squid · fedoraproject/fedora · netapp/bluexp
Source
security-advisories@github.com
EPSS trend
0%35%70%3 November 2026: 65.25%3 November 20263 November 2026

EPSS 65.3% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.