CVE-2023-1277
A vulnerability, which was classified as critical, was found in kylin-system-updater up to 1.4.20kord on Ubuntu Kylin.
Does this matter?
High impact if exploited, but EPSS currently rates exploitation as unlikely (1.80%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.
Description
A vulnerability, which was classified as critical, was found in kylin-system-updater up to 1.4.20kord on Ubuntu Kylin. Affected is the function InstallSnap of the component Update Handler. The manipulation leads to command injection. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-222600.
- CVSS 3.1
- 7.8 HIGHCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- 1.80% probability · 78th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-77, CWE-78
- Affected
- ubuntukylin/kylin-system-updater
- Source
- cna@vuldb.com
EPSS 1.8% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/cn-lwj/vuldb/blob/master/kylin-system-updater_vuln.mdExploit, Third Party Advisory
- https://vuldb.com/?ctiid.222600Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222600Third Party Advisory
- https://github.com/cn-lwj/vuldb/blob/master/kylin-system-updater_vuln.mdExploit, Third Party Advisory
- https://vuldb.com/?ctiid.222600Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222600Third Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.