SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2022-28730

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.

MEDIUM 6.1EPSS 86.2%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 86.2%, higher than 100% of all known CVEs. Patch or mitigate before the next change window.

Description

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.

CVSS 3.1
6.1 MEDIUMCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
86.16% probability · 100th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-79
Affected
apache/jspwiki
Source
security@apache.org
EPSS trend
0%45%90%3 November 2026: 86.16%3 November 20263 November 2026

EPSS 86.2% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.