SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2022-21647

Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4.

CRITICAL 9.8EPSS 37.7%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 37.7%, higher than 99% of all known CVEs. Patch or mitigate before the next change window.

Description

CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.

CVSS 3.1
9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
37.67% probability · 99th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-502
Affected
codeigniter/codeigniter
Source
security-advisories@github.com
EPSS trend
0%20%40%3 November 2026: 37.67%3 November 20263 November 2026

EPSS 37.7% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.