SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2021-33036

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

HIGH 8.8EPSS 3.97%

Does this matter?

High impact if exploited, but EPSS currently rates exploitation as unlikely (3.97%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.

Description

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

CVSS 3.1
8.8 HIGHCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
3.97% probability · 90th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-24, CWE-264, CWE-22
Affected
apache/hadoop
Source
security@apache.org
EPSS trend
0%3%5%26 October 2026: 3.97%26 October 202626 October 2026

EPSS 4.0% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.