CVE-2021-32699
All versions of Pterodactyl Wings prior to `1.4.4` are vulnerable to system resource exhaustion due to improper container process limits being defined.
Does this matter?
Lower severity and a low EPSS score (0.27%). Track it; it rarely justifies an emergency change on its own.
Description
Wings is the control plane software for the open source Pterodactyl game management system. All versions of Pterodactyl Wings prior to `1.4.4` are vulnerable to system resource exhaustion due to improper container process limits being defined. A malicious user can consume more resources than intended and cause downstream impacts to other clients on the same hardware, eventually causing the physical server to stop responding. Users should upgrade to `1.4.4` to mitigate the issue. There is no non-code based workaround for impacted versions of the software. Users running customized versions of this software can manually set a PID limit for containers created.
- CVSS 3.1
- 6.5 MEDIUMCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
- EPSS
- 0.27% probability · 18th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-400, CWE-770
- Affected
- pterodactyl/wings
- Source
- security-advisories@github.com
EPSS 0.3% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/pterodactyl/wings/commit/e0078eee0a71d61573a94c75e6efcad069d78de3Patch, Third Party Advisory
- https://github.com/pterodactyl/wings/security/advisories/GHSA-jj6m-r8jc-2gp7Third Party Advisory
- https://github.com/pterodactyl/wings/commit/e0078eee0a71d61573a94c75e6efcad069d78de3Patch, Third Party Advisory
- https://github.com/pterodactyl/wings/security/advisories/GHSA-jj6m-r8jc-2gp7Third Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.