SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2021-21389

The vulnerability has been fixed in BuddyPress 7.2.1.

HIGH 8.8EPSS 14.8%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 14.8%, higher than 97% of all known CVEs. Patch or mitigate before the next change window.

Description

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

CVSS 3.1
8.8 HIGHCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
14.81% probability · 97th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-863
Affected
buddypress/buddypress
Source
security-advisories@github.com
EPSS trend
0%8%15%28 October 2026: 14.81%3 November 2026: 14.81%28 October 20263 November 2026

EPSS moved from 14.8% on 28 October 2026 to 14.8% on 3 November 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.