SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityAnalyzed

CVE-2021-21353

In pug before version 3.0.1, if a remote attacker was able to control the `pretty` option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to…

CRITICAL 9.0EPSS 4.30%

Does this matter?

High impact if exploited, but EPSS currently rates exploitation as unlikely (4.30%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.

Description

Pug is an npm package which is a high-performance template engine. In pug before version 3.0.1, if a remote attacker was able to control the `pretty` option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend. This is fixed in version 3.0.1. This advisory applies to multiple pug packages including "pug", "pug-code-gen". pug-code-gen has a backported fix at version 2.0.3. This advisory is not exploitable if there is no way for un-trusted input to be passed to pug as the `pretty` option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.

CVSS 3.1
9.0 CRITICALCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
4.30% probability · 91th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-74, CWE-94
Affected
pugjs/pug · pugjs/pug-code-gen
Source
security-advisories@github.com
EPSS trend
0%3%5%26 October 2026: 4.30%26 October 202626 October 2026

EPSS 4.3% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.