SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2021-21305

In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability.

HIGH 8.8EPSS 13.2%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 13.2%, higher than 96% of all known CVEs. Patch or mitigate before the next change window.

Description

CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The "#manipulate!" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.

CVSS 3.1
8.8 HIGHCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
13.21% probability · 96th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-74, CWE-94
Affected
carrierwave project/carrierwave
Source
security-advisories@github.com
EPSS trend
0%8%15%3 November 2026: 13.21%3 November 20263 November 2026

EPSS 13.2% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.