CVE-2021-21242
In OneDev before version 4.0.3, there is a critical vulnerability which can lead to pre-auth remote code execution.
Does this matter?
EPSS puts the probability of exploitation in the next 30 days at 74.2%, higher than 99% of all known CVEs. Patch or mitigate before the next change window.
Description
OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, there is a critical vulnerability which can lead to pre-auth remote code execution. AttachmentUploadServlet deserializes untrusted data from the `Attachment-Support` header. This Servlet does not enforce any authentication or authorization checks. This issue may lead to pre-auth remote code execution. This issue was fixed in 4.0.3 by removing AttachmentUploadServlet and not using deserialization
- CVSS 3.1
- 9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- 74.19% probability · 99th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-74, CWE-502
- Affected
- onedev project/onedev
- Source
- security-advisories@github.com
EPSS 74.2% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9bePatch, Third Party Advisory
- https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8Third Party Advisory
- https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9bePatch, Third Party Advisory
- https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8Third Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.