CVE-2020-5284
Next.js versions before 9.3.2 have a directory traversal vulnerability.
Does this matter?
EPSS puts the probability of exploitation in the next 30 days at 44.8%, higher than 99% of all known CVEs. Patch or mitigate before the next change window.
Description
Next.js versions before 9.3.2 have a directory traversal vulnerability. Attackers could craft special requests to access files in the dist directory (.next). This does not affect files outside of the dist directory (.next). In general, the dist directory only holds build assets unless your application intentionally stores other assets under this directory. This issue is fixed in version 9.3.2.
- CVSS 3.1
- 4.3 MEDIUMCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- 44.78% probability · 99th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-23, CWE-22
- Affected
- zeit/next.js
- Source
- security-advisories@github.com
EPSS 44.8% since 3 November 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/zeit/next.js/releases/tag/v9.3.2Release Notes
- https://github.com/zeit/next.js/security/advisories/GHSA-fq77-7p7r-83rjThird Party Advisory
- https://github.com/zeit/next.js/releases/tag/v9.3.2Release Notes
- https://github.com/zeit/next.js/security/advisories/GHSA-fq77-7p7r-83rjThird Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.