CVE-2020-5263
auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability.
Does this matter?
Lower severity and a low EPSS score (0.87%). Track it; it rarely justifies an emergency change on its own.
Description
auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3
- CVSS 3.1
- 4.9 MEDIUMCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- EPSS
- 0.87% probability · 59th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-522
- Affected
- auth0/auth0.js
- Source
- security-advisories@github.com
EPSS 0.9% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/auth0/auth0.js/commit/355ca749b229fb93142f0b3978399b248d710828Patch, Third Party Advisory
- https://github.com/auth0/auth0.js/security/advisories/GHSA-prfq-f66g-43mpThird Party Advisory
- https://github.com/auth0/auth0.js/commit/355ca749b229fb93142f0b3978399b248d710828Patch, Third Party Advisory
- https://github.com/auth0/auth0.js/security/advisories/GHSA-prfq-f66g-43mpThird Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.