SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2020-5216

In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0.

MEDIUM 5.8EPSS 1.21%

Does this matter?

Lower severity and a low EPSS score (1.21%). Track it; it rarely justifies an emergency change on its own.

Description

In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.

CVSS 3.1
5.8 MEDIUMCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
1.21% probability · 68th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-113, CWE-74
Affected
twitter/secure headers
Source
security-advisories@github.com
EPSS trend
0%3%5%26 October 2026: 1.21%26 October 202626 October 2026

EPSS 1.2% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.