SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2020-25698

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course.

HIGH 7.5EPSS 1.92%

Does this matter?

High impact if exploited, but EPSS currently rates exploitation as unlikely (1.92%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.

Description

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

CVSS 3.1
7.5 HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
1.92% probability · 80th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-284
Affected
moodle/moodle · fedoraproject/fedora
Source
secalert@redhat.com
EPSS trend
0%3%5%26 October 2026: 1.92%26 October 202626 October 2026

EPSS 1.9% since 26 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.