CVE-2020-15148
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input.
Does this matter?
EPSS puts the probability of exploitation in the next 30 days at 77.5%, higher than 100% of all known CVEs. Patch or mitigate before the next change window.
Description
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.
- CVSS 3.1
- 10.0 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- 77.54% probability · 100th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-502
- Affected
- yiiframework/yii
- Source
- security-advisories@github.com
EPSS moved from 77.5% on 3 October 2026 to 77.5% on 3 November 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.
References
- https://github.com/yiisoft/yii2/commit/9abccb96d7c5ddb569f92d1a748f50ee9b3e2b99Patch, Third Party Advisory
- https://github.com/yiisoft/yii2/security/advisories/GHSA-699q-wcff-g9mjMitigation, Third Party Advisory
- https://github.com/yiisoft/yii2/commit/9abccb96d7c5ddb569f92d1a748f50ee9b3e2b99Patch, Third Party Advisory
- https://github.com/yiisoft/yii2/security/advisories/GHSA-699q-wcff-g9mjMitigation, Third Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.