SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2018-25088

A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2.

CRITICAL 9.8EPSS 0.73%

Does this matter?

High impact if exploited, but EPSS currently rates exploitation as unlikely (0.73%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit.

Description

A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2. Affected is the function _create_pg_connection/create_postgres_db of the file postgraas_server/backends/postgres_cluster/postgres_cluster_driver.py of the component PostgreSQL Backend Handler. The manipulation leads to sql injection. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 7cd8d016edc74a78af0d81c948bfafbcc93c937c. It is recommended to upgrade the affected component. VDB-234246 is the identifier assigned to this vulnerability.

CVSS 3.1
9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.73% probability · 54th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-89
Affected
blueyonder/postgraas server
Source
cna@vuldb.com
EPSS trend
0%3%5%27 October 2026: 0.73%27 October 202627 October 2026

EPSS 0.7% since 27 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.