SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2018-1000168

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service.

HIGH 7.5EPSS 10.6%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 10.6%, higher than 96% of all known CVEs. Patch or mitigate before the next change window.

Description

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

CVSS 3.1
7.5 HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
10.58% probability · 96th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-20, CWE-476
Affected
nghttp2/nghttp2 · nodejs/node.js · debian/debian linux
Source
cve@mitre.org
EPSS trend
0%8%15%27 October 2026: 10.58%27 October 202627 October 2026

EPSS 10.6% since 27 October 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.