CVE-2017-7478
OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet.
Does this matter?
EPSS puts the probability of exploitation in the next 30 days at 13.8%, higher than 96% of all known CVEs. Patch or mitigate before the next change window.
Description
OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.
- CVSS 3.0
- 7.5 HIGHCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- 13.78% probability · 96th percentile
- Public exploits
- 1 in Exploit-DB · verified · first 11 May 2017
- CISA KEV
- Not listed
- Weakness
- CWE-617, CWE-20
- Affected
- openvpn/openvpn
- Source
- secalert@redhat.com
EPSS moved from 11.6% on 21 September 2026 to 13.8% on 27 October 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.
Public exploits (1)
Entries in Exploit-DB that cite this CVE. Links go to the Exploit-DB page and to the file in the public repository; nothing is hosted here. A verified tick means the Exploit-DB team confirmed the exploit works against the stated version.
References
- http://www.securityfocus.com/bid/98444
- http://www.securitytracker.com/id/1038473
- https://community.openvpn.net/openvpn/wiki/QuarkslabAndCryptographyEngineerAuditsVendor Advisory
- https://www.exploit-db.com/exploits/41993/
- http://www.securityfocus.com/bid/98444
- http://www.securitytracker.com/id/1038473
- https://community.openvpn.net/openvpn/wiki/QuarkslabAndCryptographyEngineerAuditsVendor Advisory
- https://www.exploit-db.com/exploits/41993/
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.