CVE-2017-20181
A vulnerability classified as critical was found in hgzojer Vocable Trainer up to 1.3.0 on Android.
Does this matter?
Lower severity and a low EPSS score (0.27%). Track it; it rarely justifies an emergency change on its own.
Description
A vulnerability classified as critical was found in hgzojer Vocable Trainer up to 1.3.0 on Android. This vulnerability affects unknown code of the file src/at/hgz/vocabletrainer/VocableTrainerProvider.java. The manipulation leads to path traversal. Attacking locally is a requirement. Upgrading to version 1.3.1 is able to address this issue. The name of the patch is accf6838078f8eb105cfc7865aba5c705fb68426. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222328.
- CVSS 3.1
- 5.5 MEDIUMCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- 0.27% probability · 18th percentile
- Public exploits
- None in Exploit-DB
- CISA KEV
- Not listed
- Weakness
- CWE-22
- Affected
- vocable trainer project/vocable trainer
- Source
- cna@vuldb.com
EPSS 0.3% since 27 October 2026; no change recorded yet. Points are recorded when the score first appears and whenever it moves by a percentage point or more.
References
- https://github.com/hgzojer/vocabletrainer/commit/accf6838078f8eb105cfc7865aba5c705fb68426Patch
- https://github.com/hgzojer/vocabletrainer/releases/tag/v1.3.1Release Notes
- https://vuldb.com/?ctiid.222328Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222328Third Party Advisory
- https://github.com/hgzojer/vocabletrainer/commit/accf6838078f8eb105cfc7865aba5c705fb68426Patch
- https://github.com/hgzojer/vocabletrainer/releases/tag/v1.3.1Release Notes
- https://vuldb.com/?ctiid.222328Permissions Required, Third Party Advisory
- https://vuldb.com/?id.222328Third Party Advisory
Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.