SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2017-15708

In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI).

CRITICAL 9.8EPSS 17.9%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 17.9%, higher than 97% of all known CVEs. Patch or mitigate before the next change window.

Description

In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.

CVSS 3.1
9.8 CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
17.88% probability · 97th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-74
Affected
apache/synapse · oracle/financial services market risk measurement and management · oracle/peoplesoft enterprise peopletools
Source
security@apache.org
EPSS trend
0%10%20%27 October 2026: 17.88%27 October 202627 October 2026

EPSS 17.9% since 27 October 2026; no change recorded yet. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”. Points are recorded when the score first appears and whenever it moves by a percentage point or more.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.