SOC status:Duty analyst on shift

UK Cyber Defence
VulnerabilityModified

CVE-2017-1000479

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set.

HIGH 8.8EPSS 31.7%

Does this matter?

EPSS puts the probability of exploitation in the next 30 days at 31.7%, higher than 98% of all known CVEs. Patch or mitigate before the next change window.

Description

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.

CVSS 3.0
8.8 HIGHCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
31.70% probability · 98th percentile
Public exploits
None in Exploit-DB
CISA KEV
Not listed
Weakness
CWE-352
Affected
netgate/pfsense · opnsense project/opnsense
Source
cve@mitre.org
EPSS trend
0%18%35%21 September 2026: 31.73%22 September 2026: 32.77%28 September 2026: 31.70%27 October 2026: 31.70%21 September 202627 October 2026

EPSS moved from 31.7% on 21 September 2026 to 31.7% on 27 October 2026, peaking at 32.8% on 22 September 2026. The dashed line is the ten per cent mark our analysts treat as “patch before the next change window”.

Source: NVD record, EPSS from FIRST.org, KEV from CISA, exploits from Exploit-DB. Refreshed daily. Download this record as JSON.