{"id":"CVE-2026-85314","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-85314","generatedAt":"2026-10-28T06:35:35.493Z","title":"Improper Input Validation vulnerability in Apache Camel Mail component.","description":"Improper Input Validation vulnerability in Apache Camel Mail component.\n\nThis issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.\n\nCVE-2026-46584 addressed mail headers reaching the Exchange without passing through a header filter, but the MimeMultipart data format retained an unfiltered path: unmarshalling a multipart message mapped mail.smtp headers onto the Exchange with no filter applied. Those names sit outside the Camel namespace that consumer filters block, so a message crafted by an external sender could still set them, and the mail.smtp namespace influences how a downstream mail producer connects and sends. This is an incomplete fix of CVE-2026-46584 rather than a new class of defect: a deployment that applied that advisory and considered camel-mail settled remained exposed on this path.\n\nUpgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The MimeMultipart data format now applies the header filter on unmarshal, closing the path CVE-2026-46584 left open. For deployments that cannot upgrade immediately, strip the namespace after the data format with removeHeaders(\"mail.smtp*\") before any mail producer.","published":"2026-10-19T11:17:25.000Z","lastModified":"2026-10-19T20:45:52.000Z","status":"Awaiting Analysis","sourceIdentifier":"security@apache.org","cvss":{"version":"3.1","score":6.5,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N"},"cwe":["CWE-20"],"affected":[],"epss":{"score":0.00278,"percentile":0.20108,"date":"2026-10-27","history":[{"date":"2026-10-20","score":0.00372,"percentile":0.29755}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.28%). Track it; it rarely justifies an emergency change on its own."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-19T11:17:25.000Z","detail":{"score":"6.5","severity":"MEDIUM","publishedAt":"2026-10-19T11:17:24.700Z"},"summary":"New CVE, medium severity (CVSS 6.5)."}],"references":[{"url":"https://camel.apache.org/security/CVE-2026-85314.html","source":"security@apache.org"},{"url":"https://github.com/apache/camel/pull/25568","source":"security@apache.org"},{"url":"https://github.com/apache/camel/pull/25765","source":"security@apache.org"},{"url":"https://github.com/apache/camel/pull/25766","source":"security@apache.org"},{"url":"https://issues.apache.org/jira/browse/CAMEL-24419","source":"security@apache.org"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-85314","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}