{"id":"CVE-2026-85247","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-85247","generatedAt":"2026-10-28T04:14:26.115Z","title":"Improper Certificate Validation vulnerability in Apache Camel Knative component.","description":"Improper Certificate Validation vulnerability in Apache Camel Knative component.\n\nThis issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.\n\nWhen SSL was enabled on the Knative HTTP client but no truststore was configured, the client options fell back to trusting every presented certificate rather than to the JVM's default trust anchors. A deployment that switched TLS on without also configuring a truststore therefore obtained an encrypted connection with no peer authentication, which an attacker positioned on the network path can terminate and read. The dangerous state is reached by omission rather than by an explicit opt-in, which is what makes it a framework defect: turning TLS on should not be the thing that turns certificate validation off.\n\nUpgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. With no truststore configured the trust options are now left unset so the JVM default trust anchors apply, the same fallback SSLContextParameters and the rest of Camel use. Trusting every certificate is now reached only by asking for it explicitly through the trust.all property, which remains available for development against a cluster with a self-signed certificate. For deployments that cannot upgrade immediately, configure a truststore explicitly wherever SSL is enabled. After upgrading, a deployment that was relying on the implicit trust-all behaviour must either configure a truststore or set the trust.all property deliberately.","published":"2026-10-19T11:17:23.000Z","lastModified":"2026-10-19T20:45:52.000Z","status":"Awaiting Analysis","sourceIdentifier":"security@apache.org","cvss":{"version":"3.1","score":5.9,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N"},"cwe":["CWE-295"],"affected":[],"epss":{"score":0.00423,"percentile":0.36421,"date":"2026-10-27","history":[{"date":"2026-10-20","score":0.00307,"percentile":0.22147}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.42%). Track it; it rarely justifies an emergency change on its own."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-19T11:17:23.000Z","detail":{"score":"5.9","severity":"MEDIUM","publishedAt":"2026-10-19T11:17:22.820Z"},"summary":"New CVE, medium severity (CVSS 5.9)."}],"references":[{"url":"https://camel.apache.org/security/CVE-2026-85247.html","source":"security@apache.org"},{"url":"https://github.com/apache/camel/pull/25824","source":"security@apache.org"},{"url":"https://github.com/apache/camel/pull/25944","source":"security@apache.org"},{"url":"https://github.com/apache/camel/pull/25946","source":"security@apache.org"},{"url":"https://issues.apache.org/jira/browse/CAMEL-24443","source":"security@apache.org"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-85247","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}