{"id":"CVE-2026-84377","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-84377","generatedAt":"2026-10-28T00:14:50.907Z","title":"Routing and credential parameters including api_base, base_url, model_list, fallbacks, and litellm_credential_name could therefore be applied without clearing the operator's stored key, exposing upstream provider credentials and other configured secrets…","description":"LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to versions 1.88.6 and 1.96.2, any authenticated LiteLLM proxy user could redirect an outbound provider call to a destination the user controls and cause the proxy to send its configured provider credentials to that destination. Request validation in litellm/proxy/auth/auth_utils.py, litellm/proxy/common_request_processing.py, litellm/proxy/health_endpoints/_health_endpoints.py, litellm/proxy/image_endpoints/endpoints.py, and litellm/proxy/litellm_pre_call_utils.py used incomplete checks that did not cover every sensitive parameter or inspect equivalent values across nested request fields, path values, and bracket-notation form data. Routing and credential parameters including api_base, base_url, model_list, fallbacks, and litellm_credential_name could therefore be applied without clearing the operator's stored key, exposing upstream provider credentials and other configured secrets and permitting server-side requests to internal services reachable by the proxy. This issue is fixed in versions 1.88.6 and 1.96.2.","published":"2026-09-02T18:21:29.000Z","lastModified":"2026-09-09T21:05:23.000Z","status":"Awaiting Analysis","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":6.5,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"},"cwe":["CWE-918"],"affected":[],"epss":{"score":0.0054,"percentile":0.45147,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.54%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://github.com/BerriAI/litellm/commit/473f72e63a9777d793fbbf57194d8ec4fb97bc1b","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/commit/820f247a6abba55cd87d130bef7bba7be3b29d37","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/commit/c898d341c02299cf2506d0d8e84cc67953043593","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/pull/36011","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/pull/36314","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/pull/36494","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/releases/tag/v1.88.6","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/releases/tag/v1.96.2","source":"security-advisories@github.com"},{"url":"https://github.com/BerriAI/litellm/security/advisories/GHSA-3cv6-jpf6-8222","source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-84377","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}