{"id":"CVE-2026-84314","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-84314","generatedAt":"2026-10-28T01:02:40.638Z","title":"An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator.","description":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.","published":"2026-10-12T21:17:22.000Z","lastModified":"2026-10-13T18:17:26.000Z","status":"Deferred","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"4.0","score":8.7,"severity":"HIGH","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M"},"cwe":["CWE-285","CWE-862"],"affected":[],"epss":{"score":0.00419,"percentile":0.35966,"date":"2026-10-26","history":[{"date":"2026-10-13","score":0.0033,"percentile":0.24262}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.42%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-12T21:17:22.000Z","detail":{"score":"8.7","severity":"HIGH","publishedAt":"2026-10-12T21:17:21.753Z"},"summary":"New CVE, high severity (CVSS 8.7)."}],"references":[{"url":"https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","source":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1","source":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","source":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","source":"134c704f-9b21-4f2e-91b3-4a467353bcc0"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-84314","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}