{"id":"CVE-2026-79920","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-79920","generatedAt":"2026-10-28T05:59:46.714Z","title":"A low-privileged user can therefore select or manipulate a package installed with root privileges and can install, remove, or upgrade plugins without administrative permission, resulting in root code execution and full host compromise.","description":"Ajenti is a Linux & BSD modular server admin panel. Prior to version 2.2.16, any authenticated user can call /api/core/tasks/start to enqueue InstallPlugin, UnInstallPlugin, or UpgradeAll from plugins/plugins/tasks.py without plugin-management authorization. InstallPlugin and UnInstallPlugin construct a pip package specification from unvalidated name and version fields, and the task worker invokes pip while running as root. A low-privileged user can therefore select or manipulate a package installed with root privileges and can install, remove, or upgrade plugins without administrative permission, resulting in root code execution and full host compromise. This issue is fixed in version 2.2.16.","published":"2026-09-21T17:19:00.000Z","lastModified":"2026-09-24T21:25:27.000Z","status":"Deferred","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":9.9,"severity":"CRITICAL","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H"},"cwe":["CWE-862"],"affected":[],"epss":{"score":0.00624,"percentile":0.49738,"date":"2026-10-27","history":[{"date":"2026-09-22","score":0.00358,"percentile":0.29572}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.62%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-09-21T17:19:00.000Z","detail":{"score":"9.9","severity":"CRITICAL","publishedAt":"2026-09-21T17:18:59.567Z"},"summary":"New CVE, critical severity (CVSS 9.9)."}],"references":[{"url":"https://github.com/ajenti/ajenti/commit/3a8cbee32df4c5033796f19af4210011163a6f6e","source":"security-advisories@github.com"},{"url":"https://github.com/ajenti/ajenti/commit/f07f02e0cdeeb3e528c1d5af28e27fd11623c49c","source":"security-advisories@github.com"},{"url":"https://github.com/ajenti/ajenti/releases/tag/v2.2.16","source":"security-advisories@github.com"},{"url":"https://github.com/ajenti/ajenti/security/advisories/GHSA-j8xf-5fw2-f99q","source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-79920","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}